Text Delivery Status
Incident Report for GreySignal
Resolved
This has been resolved
Posted Jun 26, 2020 - 13:09 EDT
Investigating
We are investigating an issue with incorrect delivery statuses on text messages within the Mass Notifications module. Users may see a "Sending" status when messages have already been delivered.
Posted Jun 26, 2020 - 12:29 EDT
This incident affected: GreyMAR (Texting Services).